[ckan-dev] localhost /group infinite redirect loop with paster server

Luke Tully luke at luketully.ca
Fri Jul 13 04:28:49 UTC 2018

Hi Everyone,

I’ve been trying to diagnose this error for a while, as such I’ve posted a
similar question on StackOverflow
in the https://github.com/ckan/ckan/issues/4331(reluctantly, I know it’s
pretty backed up at the moment).

At this point, I’m not receiving any internal server errors, but /group
creates an infinite redirect loop in every local configuration I have tried
so far. Originally, I was working off a locally hosted instance of 2.6.3
that had been duped from one running on an Ubuntu 14.04 instance that
doesn’t have this problem either with or without paster. Since then, I’ve
tried installing a few different CKAN versions with fresh databases,
flushed redis caches, cleared solr indexes and so on, but with no success
in avoiding this so far.

The reason I have it set up locally on my mac in the first place is for
debugging purposes during development. Using the same process—visual
breakpoint based debugging in PyCharm—I haven’t yet been able to track down
why a 301 recursive redirect is being sent back in the first response.

I initially thought that ckanext-scheming and ckanext-harvester might have
been complicating the situation. These are being used on the machine that I
duplicated my local instance from and I’ve done a few harvests from
multiple remote CKAN sites. As part of troubleshooting this I’ve of course
cleared the DB and tried disabling all plugins from the equation. I’ve also
ensured that all url config options are set correctly.

Has anyone run into anything like this before?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/ckan-dev/attachments/20180712/a18a9871/attachment.html>

More information about the ckan-dev mailing list