[ckan-dev] CKAN-EXT harvester execution problems

Bäuml, Daniel daniel.baeuml at scs.fraunhofer.de
Tue Jan 22 13:54:07 UTC 2019

Hi Kevin,

thanks! That worked out quite well with changing the password back to the default value.
Everything is fixed now.

Best regards

Von: ckan-dev <ckan-dev-bounces at lists.okfn.org> Im Auftrag von Kevin Brochet-Nguyen
Gesendet: Freitag, 18. Januar 2019 13:07
An: CKAN Development Discussions <ckan-dev at lists.okfn.org>
Betreff: Re: [ckan-dev] CKAN-EXT harvester execution problems

The installation instructions do indeed imply that you can use any password:

Next you’ll need to create a database user if one doesn’t already exist. Create a new PostgreSQL database user called ckan_default, and enter a password for the user when prompted. You’ll need this password later:

sudo -u postgres createuser -S -D -R -P ckan_default

On Fri, Jan 18, 2019 at 1:03 PM Kevin Brochet-Nguyen <kevin at viderum.com<mailto:kevin at viderum.com>> wrote:
Regarding the first issue, did you set the password for the ckan_default to `pass`? That's what test-core.ini uses. I ran into problems in the past when I setup CKAN and gave the ckan_default user a different password. I don't think the instructions for installing CKAN ever mention that the tests require that your ckan_default user's password has to be `pass`.

On Fri, Jan 18, 2019 at 12:54 PM Kevin Brochet-Nguyen <kevin at viderum.com<mailto:kevin at viderum.com>> wrote:
Hi Daniel,

You need to pip install -r ckanext-harvest/dev-requirements.txt in order to run the harvester tests. That will resolve your second issue. Not sure about the first one.

Kind regards,

On Fri, Jan 18, 2019 at 12:35 PM Bäuml, Daniel <daniel.baeuml at scs.fraunhofer.de<mailto:daniel.baeuml at scs.fraunhofer.de>> wrote:
Hi to everyone,

I installed CKAN 2.8.2 and the ckan harvester extension.
However, I got some problem when trying to run the harvester.

First, if I try to execute the tests for the harvester with the command:
        nosetests --reset-db --ckan --with-pylons=test-core.ini ckanext/harvest/tests
I get an error message - FATAL: password authentication failed for user "ckan_default".
But if I can login with the credentials to postgres on the command line and everything works.
The credentials are also changed in the config file and the init command works fine.

Secondly, trying to execute the harverster import on command line with:
        paster --plugin=ckanext-harvest harvester run_test --config=/etc/ckan/default/production.ini
This leads me always to the python error - "ImportError: No module named factory"

Any hints what I'm doing wrong?

ckan-dev mailing list
ckan-dev at lists.okfn.org<mailto:ckan-dev at lists.okfn.org>
Unsubscribe: https://lists.okfn.org/mailman/options/ckan-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/ckan-dev/attachments/20190122/65f14c5c/attachment-0002.html>

More information about the ckan-dev mailing list