[ckan-dev] Problem with 'ghost' dataset

Stefan Oderbolz odi at metaodi.ch
Thu Jul 25 05:41:10 UTC 2019

Hi Aaron

This sounds like a problem with the Solr index, i.e. the information in the
index differs from the information in the database. Maybe in the whole
deleting/purging process the old "ghost" dataset was not removed from the
Solr index.
So I would first of all rebuild the index and check if It works as expected.

- Stefan

On Thu, Jul 25, 2019, 02:19 Aaron McGlinchy <
McGlinchyA at landcareresearch.co.nz> wrote:

> Hi, we are using CKAN 2.7.2 (which we do need to update).
> I created a dataset, during which I edited the URL ckan assigned by
> default.  On the face of it the dataset created properly, once I'd uploaded
> resource and saved, it looked as expected.  I sent the URL to someone else
> to look at and it worked.
> The problem is that the dataset doesn't show up in the list of datasets,
> nor within an organisation.  The dataset is set to public, and I am logged
> in as sysadmin.  Thus there is no way for anyone else to find or see this
> dataset, unless they already know the URL.
> I tried to rectify it by creating another dataset to see if it showed up
> as expected (it did).  I then copied the metadata and data resources over
> to the new dataset, deleted the old 'ghost' dataset (purged the trash, but
> got an error message (integrity error on table resource..., though the
> dataset did disappear from the trash), I then edited the URL to what the
> 'ghost' dataset had - it failed 'URL already in use', so I changed it to a
> slightly different URL.
> But now that dataset has issues - it is set to Public, and when I open the
> dataset it doesn't show the private 'flag' at the top right, BUT when I
> look at the list of datasets/datasets within an organisation, the private
> flag is showing.  If I log out I cannot see the dataset in the list (it's
> treating it as private), but if I enter the URL directly it will open the
> dataset (treating as public).  I tired editing the datastet and toggling
> the visibility from public to private and back again to see if that would
> reset things, but no joy.
> So I'm after any ideas on how to fix my problem dataset, and to flag that
> their may be a bug that occurs when you edit a datasets URL that messes
> things up.
> Thanks
> Aaron
> ________________________________
> Please consider the environment before printing this email
> Warning: This electronic message together with any attachments is
> confidential. If you receive it in error: (i) you must not read, use,
> disclose, copy or retain it; (ii) please contact the sender immediately by
> reply email and then delete the emails.
> The views expressed in this email may not be those of Landcare Research
> New Zealand Limited. http://www.landcareresearch.co.nz
> _______________________________________________
> ckan-dev mailing list
> ckan-dev at lists.okfn.org
> https://lists.okfn.org/mailman/listinfo/ckan-dev
> Unsubscribe: https://lists.okfn.org/mailman/options/ckan-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/ckan-dev/attachments/20190725/8c04a655/attachment-0002.html>

More information about the ckan-dev mailing list