[ckan-discuss] Failed to initialise CKAN database

Richard.Goh at csiro.au Richard.Goh at csiro.au
Wed Aug 14 07:51:35 BST 2013

Hi all,

I followed the following link to install CKAN (http://docs.ckan.org/en/latest/install-from-package.html).

I encountered the following error when I was trying to initialise CKAN database (sudo ckan db init):

Traceback (most recent call last):
  File "/usr/lib/python2.7/compiler/__init__.py", line 29, in <module>
    from compiler.transformer import parse, parseFile
  File "/usr/lib/python2.7/compiler/transformer.py", line 29, in <module>
    import parser
ImportError: /usr/lib/ckan/default/lib/python2.7/lib-dynload/parser.so: undefined symbol: _PyNode_SizeOf

I tried to re-initialise virtualenv with "virtualenv --system-site-packages ." and also tried paster CLI without any luck.

Has anyone encountered the same error and what was your solution?

Richard Goh

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/ckan-discuss/attachments/20130814/56c7ce69/attachment.htm>

More information about the ckan-discuss mailing list