[ckan-discuss] running ckan

Javier Coque Garcia coque_losel at hotmail.com
Fri Jul 26 13:20:46 BST 2013

Hi!! I installed CKAN in my host, and y created a user three days ago, and all worked quite good. But today, when I ran the CKAN, I wrote that comands, the shell showed me that message error:

sudo /etc/init.d/postgresql start
. /usr/lib/ckan/default/bin/activate
cd /usr/lib/ckan/default/src/ckan
paster serve /etc/ckan/default/development.ini

2013-07-26 13:11:56,388 ERROR [ckan.lib.search.common] [Errno 111] Connection refused
Traceback (most recent call last):
  File "/home/sig/ckan/lib/default/src/ckan/ckan/lib/search/common.py", line 51, in is_available
    conn.query("*:*", rows=1)
  File "/usr/lib/ckan/default/local/lib/python2.7/site-packages/solr/core.py", line 703, in query
    return self.select(*args, **params)
  File "/usr/lib/ckan/default/local/lib/python2.7/site-packages/solr/core.py", line 798, in __call__
    xml = self.raw(**params)
  File "/usr/lib/ckan/default/local/lib/python2.7/site-packages/solr/core.py", line 823, in raw
    rsp = conn._post(self.selector, request, conn.form_headers)
  File "/usr/lib/ckan/default/local/lib/python2.7/site-packages/solr/core.py", line 646, in _post
  File "/usr/lib/ckan/default/local/lib/python2.7/site-packages/solr/core.py", line 625, in _reconnect
  File "/usr/lib/python2.7/httplib.py", line 772, in connect
    self.timeout, self.source_address)
  File "/usr/lib/python2.7/socket.py", line 571, in create_connection
    raise err
error: [Errno 111] Connection refused
2013-07-26 13:11:56,393 WARNI [ckan.lib.search] Problems were found while connecting to the SOLR server
Starting server in PID 9835.
serving on view at

how can I fix it?

Thank you so much.

Yours faithfully.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/ckan-discuss/attachments/20130726/8f4876bb/attachment.htm>

More information about the ckan-discuss mailing list