[ckan-discuss] ckanext-spatial and PostGIS 9.3

Adrià Mercader adria.mercader at okfn.org
Wed May 21 14:43:21 UTC 2014

Hi Henrik,

I'm assuming you mean PostGIS 2.0? I would expect Postgres 9.3 to work fine.

PostGIS 2.0 is more complicated though, basically as it stands now
ckanext-spatial won't work with PostGIS 2.0 because geoalchemy does
not support it. To do so we need to upgrade to geoalchemy2. The
problem with this is that it requires SQLAlchemy 0.8.x. The current
requirement for CKAN is 0.7.x. This will get upgraded on the next
release but you can already manually upgrade it [1].

I have adding support for geoalchemy2 [2] on my TODO list, and once
this is done, the way to test it would be:

* Update ckanext-spatial
* Upgrade SQLAlchemy to 0.8.x [3]
* Install geoalchemy2

I'll let the list know when I've updated ckanext-spatial


[1] https://github.com/ckan/ckan/pull/1427
[2] https://github.com/ckan/ckanext-spatial/issues/5
[3] https://github.com/ckan/ckan/wiki/Upgrading-to-SQLAlchemy-0.8

On 19 May 2014 11:17, Henrik Aagaard Sørensen <BU1G at tmf.kk.dk> wrote:
> Does anyone have experience with upgrading PostGIS to version 9.3 when using
> ckanext-spatial?
> _______________________________________________
> ckan-discuss mailing list
> ckan-discuss at lists.okfn.org
> https://lists.okfn.org/mailman/listinfo/ckan-discuss
> Unsubscribe: https://lists.okfn.org/mailman/options/ckan-discuss

More information about the ckan-discuss mailing list