[ckan4rdm] Can't get datastore to install

Claire Reis Claire.Reis at umanitoba.ca
Wed Oct 29 14:23:41 UTC 2014

We have recently installed CKAN 2.2 from package on an Ubuntu 12.0.04 machine.  WE have gotten the file upload plugin working, but cannot get the datastore working.  We get all the way through to set permissions (which seems to work) but when we test the set-up with the curl GET command the error returned is can't connect to host.
I have even gone in and looked at the set_permissions.sql file which did not in fact seemed to be changed, and changed the settings to:
Main CKAN database: ckan_default
Datastoredb: datastore_default
CKANuser postgres: ckan_default (also tried postgres)
Datastore user that can write and read: datastore_default

We initially followed the instructions from
and used Option 1 - paster command but couldn't get the test to work so moved to option 3 - and copied the set_permissions.sql file to set_permissions_new.sql file where I changed the above settings, ran the sudo -u postgres psql postgres -f set_permissions_new.sql - which seemed to work and tried the curl test-set-up again which still fails.

Any suggestions?

In the SQL database, there is a database named ckan_default with ckan_default owner and datastore_default with ckan_default owner.  There is also a user - datastore_default.  All databases are UTF-8 encoded.

Thank you,

Claire Herbert
Lake Winnipeg Basin Information Network

Centre For Earth Observation Science
Department of Environment and Geography
522 Wallace Building
University of Manitoba
Winnipeg, Canada, R3T 3N2
Phone: (204) 474-8657

Follow us on twitter - @LWBIN_UM
Web: http://lwbi.cc.umanitoba.ca/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/ckan4rdm/attachments/20141029/b79654be/attachment-0002.html>

More information about the ckan4rdm mailing list