[kforge-dev] naming for events/event handlers

Rufus Pollock rufus.pollock at okfn.org
Fri Sep 16 15:26:47 UTC 2005

Kforge uses a centralized event notification system driven of 
kforge.plugin.PluginController. John who designed the system intends to 
post more about this to the list soon but in the mean time i wanted to 
raise the issue naming for method event handlers (which in turn is 
naming for events themselves). For example currently we have:


1. would it better to have  'create' rather than 'new' (note we also 
have things like onNewProject, onApproveProject, onDeleteProject)

2. Should we have (as currently)




3. should we have more temporal qualifiers such as 'after' and 'before'


More information about the kforge-dev mailing list