[wdmmg-dev] refactor .lib.solrhelp and .lib.browser into .lib.solr

Rufus Pollock rufus.pollock at okfn.org
Tue May 17 13:15:04 UTC 2011

On 15 May 2011 21:48, Carsten Senger <senger at rehfisch.de> wrote:
>>>> and rename .lib.browser.Browser to .lib.browser.SolrBrowser.
>>> No objections here.
>> I don't fully get why it needs to be renamed, but go ahead ;-)
> Only for clarity. Gardening. Both work with solr, and Browser is
> a very common name which gives no hints about it's purpose.

Understood. Given amount of stuff we have to do i think we could focus
on other stuff :-)
>>> PS: i think you should check suggestion about entry id naming with
>>> Friedrich. I also think that (as per ticket) we should have some human
>>> / search engine url niceness so urls were of the form:
>>> /entry/{id}/{string-for-humans-but-not-used-by-backend}
> I thought so too, but I started with the eu dataset and it has nothing
> usefull to put there like transaction ids and descriptions.
> The best I can come up with looks like .../{from}-to-{to}, e.g.

I agree with you and Friedrich: forget this for entries.


More information about the openspending-dev mailing list