[annotator-dev] A question about Annotator backend

johnny jiang johnny.nan.jiang at gmail.com
Thu Apr 5 21:13:17 UTC 2012

Hi Nick,

Thanks for the link.

Actually I saw some information in there indicating that -E option has been
1.1 (2012-02-16)
Removed -E/--environment option and PIP_RESPECT_VIRTUALENV; both use a
restart-in-venv mechanism that’s broken, and neither one is useful since
every virtualenv now has pip inside it. Replace pip -E path/to/venv install
Foo with virtualenv path/to/venv &&path/to/venv/pip install Foo.

So I just tried pip install . in the root directory of annotator store,
seemed to be fine, but not sure if it is the right way.
Then I skipped source pyenv/bin/activate as I have no idea about it, then I
followed cp annotator.cfg.example annotator.cfg.
Finally I got the following when running python run.py.

ol.py", line 255, in urlopen
    raise MaxRetryError("Max retries exceeded for url: %s" % url)
pyes.urllib3.connectionpool.MaxRetryError: Max retries exceeded for url:

I use Python 2.7 and Pip 1.1, are you able to help with it? Thanks

Kind regards,

On Fri, Apr 6, 2012 at 1:19 AM, Nick Stenning <nick at whiteink.com> wrote:

> Hi Johnny,
> I have no idea what "pip" is on your system, but if it doesn't have a -E
> option I don't think it's the right thing. "pip" the python package
> installer has had "-E" since *at least* version 0.1.2, and the current
> version is 1.1!
> See http://www.pip-installer.org/en/latest/news.html
> The only other possibility which occurs to me is that pip behaves
> differently on Win32 ... but again, the page above indicates that it's
> worked on Windows for a very long time.
> Best,
> Nick
> On 5 Apr 2012, at 15:37, johnny jiang <johnny.nan.jiang at gmail.com> wrote:
> Hi folks,
> I was trying to set up a backend for annotator using the official store
> https://github.com/okfn/annotator-store
> And I was following the instructions below
> *pip -E pyenv install -e .
> source pyenv/bin/activate
> cp annotator.cfg.example annotator.cfg
> python run.py*
> then got the following error
> *E:\dev\applications\Python27\Scripts>pip -E pyenv install -e .*
> *Usage: pip-script.py COMMAND [OPTIONS]*
> *
> *
> *pip-script.py: error: no such option: -E*
> -E and -e don't seem to be valid options for pip, any advice would be
> appreciated.
> Thanks and regards,
> Johnny
> _______________________________________________
> annotator-dev mailing list
> annotator-dev at lists.okfn.org
> http://lists.okfn.org/mailman/listinfo/annotator-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/annotator-dev/attachments/20120406/3e454403/attachment-0002.html>

More information about the annotator-dev mailing list