[annotator-dev] Annotator store flask

johnny jiang johnny.nan.jiang at gmail.com
Wed Apr 18 21:58:09 UTC 2012

Hi Nick,

This problem is interesting as it happens sometimes intermittently, last
time I got it solved by the way that I cleaned up the index files, then
restarted the ES server and made it index for long enough time. It might
happen again but so far so good.

I'm trying to integrate the annotator (including annotator store and
annotator client) with my own app, and make the annotator work with the
authentication and authorization of my app. Before I just registered an
user with annotateit.org, then got a token and used it's store. But this
time I'd like to set up my own store, but I have no clue how to make the
auth happen. I checked the annotator store python code and the Wordpress
plugin, but haven't got the whole picture in terms of how auth works. Could
you please advise in some detail? Cheers.

Kind regards,

On Thu, Apr 19, 2012 at 1:46 AM, Nick Stenning <nick at whiteink.com> wrote:

> Hi Johnny,
> How quickly are you starting and quitting ElasticSearch? There shouldn't
> be anything special needed to get ES to serialise to disk, but given it
> flushes to the index asynchronously I suspect you might be able to cause
> loss of data if you kill it fast enough and sufficiently aggressively
> (SIGKILL or similar).
> If you're still seeing this, it sounds like ES is misconfigured -- perhaps
> it doesn't have appropriate permissions on its data directory?
> N
> On 11 Apr 2012, at 12:26, johnny jiang <johnny.nan.jiang at gmail.com> wrote:
> Thanks Nick, that is fair enough.
> Actually I tried annotator-store first, and got it up and running. I
> noticed that I lost all my annotations after I shut down the store and
> ElasticSearch. Is there a way to get the store permanent?
> Kind regards,
> Johnny
> On Wed, Apr 11, 2012 at 6:53 PM, Nick Stenning <nick at whiteink.com> wrote:
>> Hi Johnny,
>> That's the backend that later turned into
>> https://github.com/okfn/annotator-store
>> I have no plans to bring it up to date, and I can't really provide
>> support for it, either. Sorry!
>> Do note that it has no support for authentication or authorisation of any
>> kind.
>> Best,
>> Nick
>> On Tue, Apr 10, 2012 at 22:35, johnny jiang <johnny.nan.jiang at gmail.com>
>> wrote:
>> > Hi Nick,
>> >
>> > I'm looking through all the annotator backends, and found this one
>> really
>> > simple and easy to use.
>> > https://github.com/nickstenning/annotator-store-flask/
>> >
>> > However it seems to be a bit old, as I got Content-Type is not allowed
>> in
>> > the header when submitting annotations to it. Is there a plan to bring
>> it up
>> > to date? Or could you give me some hints so that I can  implement it
>> myself?
>> > Thanks
>> >
>> > Kind regards,
>> > Johnny
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/annotator-dev/attachments/20120419/8541a6eb/attachment-0002.html>

More information about the annotator-dev mailing list