[kforge-user] Unable to create new projects / services

tyju tiui jckdnk111 at yahoo.com
Mon Jun 21 14:22:00 UTC 2010

Hi John,

Thanks for your response.
I followed your suggestions and unfortunately it didn't seem to help.

I have more detailed info in the logs now but still no errors - everything appears to be working correctly when I examine the logs.
Here is a link to my /opt/kforge/var/log/kforge.log file during svn creation: http://jckdnk111.pastebin.com/WEy2hxVF

I am still getting a white screen when I click on the "create the service" button while trying to add a subversion repository.

Any other ideas?



----- Original Message ----
From: John Bywater <john.bywater at appropriatesoftware.net>
To: tyju tiui <jckdnk111 at yahoo.com>
Cc: kforge-user <kforge-user at lists.okfn.org>
Sent: Sat, June 19, 2010 6:34:49 AM
Subject: Re: [kforge-user] Unable to create new projects / services

Hi Ty,

Thanks for upgrading to KForge 0.17. I'm sorry to hear you're having trouble....

tyju tiui wrote:
> Hi,
> I recently upgraded to 0.17 and everything is working fine for my old projects.
> However, I just tried to create a new project and I get a plain white screen after I click "send the form".
> The project gets registered in the db and I see it in the project list, but it did not get created on the filesystem.
> If I manually create the folder on the filesystem and then try to add a svn repo the same thing happens (with the white screen).
> I switched the log level to INFO and changed the system_mode to development but I am still not seeing anything that would indicate the cause of the problem.
> The project_data_dir is owned and is writable by the apache user (and I am able to commit code to the old svn repo's for the old projects).
> Is there any way I can get kForge to print a stack trace in the browser when it fails? Or maybe is there another log outside of my apache logs and my /opt/kforge/var/log/kforge.log?

There is no other log. It does sound like trouble with permissions (but it might be something else). You could try setting the log level to DEBUG.

To get KForge to print a stack trace in the browser, set "system_mode = development" in your kforge.conf, recreate the Apache config (kforge-admin apacheconfig create), and restart Apache.

Let us know how you get on. It would be good to get the bottom of this.

Best wishes,


> Thanks,
> Ty


More information about the kforge-user mailing list