[openbiblio-dev] Issues installing open biblio

William Waites ww at eris.okfn.org
Tue Jan 25 16:48:46 UTC 2011

* [2011-01-25 15:56:27 +0000] Richard Pope <richard at memespring.co.uk> écrit:

] Rufus asked me to jot down some of the issues I had getting a dev copy
] of OpenBiblio working on a mac. I did just about get it working, and
] created an install.txt on the way:

Thank you, Richard for all your hard work. I'd ask you to create
a few tickets, mentioned below.

] - The settings file in source control is out of date, William and I
] ended up using and amending the one from the live site.

Ticket #1 - update the config template so that it reflects current

] - Installing Virtuoso is a bit of a nightmare on OSX when using
] mac-ports. Someone from Virtuoso said to use the .dmg installer, but
] I'm not sure that would have worked with my carefully balanced path
] setup.

I think you'd end up getting the commercial version of virtuoso
that way as well, which I avoid like the plague...

] - I had to install ontosrv by doing an hg clone, doing a pip install
] didnt work (although I can't remember the exact details of why).

Ticket #2 - this needs fixed, should just work with pip install 

] - Installing the requirements from pip-requirements.txt resulted in
] various errors later (again i don't have the details) so I did them
] manually and a few other things that were missing.

This has cropped up elsewhere as well, if you look at the curate
tool install instructions it has a mix of manual "pip install foo"
commands and pip-requirements.txt. It seems that pip-requirements
doesn't always install the right versions of things and in some
cases can't install things (e.g. the 4suite stuff that isn't
used in openbiblio so that's not an issue here). I guess the best
solution here is what you've done, just document the process.

] - Getting Python to talk to Virtuoso over ODBC on a mac requires
] magic. I ended up installing a random management tool (ODBC
] administrator) and trying drivers form various sources. Even now I'm
] not sure how it is working :)

I concur, ODBC configuration seems a bit of an art to me as well.

] - After loading some data I am unable to view any entries or do a
] successfull search using the OpenBiblio web interface (using the same
] SAPQRL queries directly into the Virtuoso web interface does work).

Ok, there's a missing step here, namely installing the lens that
is used to view these things. There's an ordf(1) command line that
will do this -- I'll update the instructions accordingly. Ticket #3

] In summary, I think it would be beneficial if someone who knows the
] software better than me tried to do a clean install and updated the
] various docs/settings files.

Will do. Thanks again for your help in hacking on this.

William Waites                <mailto:ww at styx.org>
http://eris.okfn.org/ww/         <sip:ww at styx.org>
F4B3 39BF E775 CF42 0BAB  3DF0 BE40 A6DF B06F FD45

More information about the openbiblio-dev mailing list