[wdmmg-dev] refactor .lib.solrhelp and .lib.browser into .lib.solr
friedrich.lindenberg at okfn.org
Sun May 15 19:31:58 UTC 2011
On Sun, May 15, 2011 at 9:16 PM, Rufus Pollock <rufus.pollock at okfn.org> wrote:
> On 15 May 2011 20:11, Carsten Senger <senger at rehfisch.de> wrote:
>> I'd like to move the content of .lib.solrhelp and .lib.browser to .lib.solr
> there's a reason it was called solrhelp: so you didn't have problems with:
> import solr
> as solr is name of underlying library.
>> and rename .lib.browser.Browser to .lib.browser.SolrBrowser.
> No objections here.
I don't fully get why it needs to be renamed, but go ahead ;-)
>> And does somebody know if these are used outside the main wdmmg package?
> Doubt it.
No, but its used pretty extensively within, so handle with some care
;) And wrt @properties take care to only make those explicit that are
about value access, not those for lazy-loading.
> PS: i think you should check suggestion about entry id naming with
> Friedrich. I also think that (as per ticket) we should have some human
> / search engine url niceness so urls were of the form:
I disagree: making up names for them introduces a new set of
parameters to the loader with no clear benefit (I doubt google does
dictionary checks on URLs). This is different from entities: I want
/.../Microsoft_Corporation, but I can't see the appeal in
More information about the openspending-dev