[kforge-dev] [kforge-user] Dependency problems installing 0.14

John Bywater john.bywater at appropriatesoftware.net
Thu Mar 20 12:32:08 UTC 2008

Hi all,

Martin Fuzzey wrote:
> I'm trying to install kForge 0.14 on Debian Etch and am running into 
> dependency problem.. 


> error: Could not find suitable distribution for 
> Requirement.parse('SQLObject>=0.6,<=0.7.99')
> Pypi currently has 0.87, 0.93 and 0.10b2 versions of SQLObject...

Just to say that, after a late night, I've fixed up domainmodel for 
SQLObject 0.10.0 (which is the latest version at this time).

Still really need to make it simultaneously compatible with 0.7, 0.8 and 
0.9, but at least I've been able to make it work with the several 
changes to the way SQLObject behaves.

However, rather ironically this morning, by accident I discovered that 
the cheeseshop appears to be serving up SQLObject 0.7.10 just fine. Back 
by popular demand? ;-)


More information about the kforge-dev mailing list