[okfn-help] [okfn-discuss] openShakespeare on Windows

Iain Emsley print.crimes at yatterings.com
Tue Mar 18 12:37:36 GMT 2008

Many thanks, Rufus. I was running it off the wrong command line, ie  
the python one not the Windows one.

I've got most of this working and am just hooking it up to MySQL so I  
can see what happening inside.

Would it be worth me writing this up for any potential Windows users  
as there are dependencies like wget which need to be added to the  
paths and so on which may not be immediately obvious?


Quoting Rufus Pollock <rufus.pollock at okfn.org>:

> Iain Emsley wrote:
>> I'm just trying to run openShakespeare on a Windows XP box but keep getting:
>>    File"<stdin">, line 1
>>    bin/shakespeare-admin runserver
>> 				  ^
> Have you been able to run other cmdline stuff e.g.
> $ bin/shakespeare-admin about
> If you get the same error with this then try:
> $ python bin/shakespeare-admin runserver
> You see the thing is that windows does not recognize the unix
> convention for specifying what program is used to run a script. At the
> beginning of that file you have
> #!/usr/bin/env python
> which tells the machine to run this using python. However windows does
> not recognize this (I believe) and so you need to run the script using
> python explicitly:
> i.e. by doing
> python <my-script-name>
>> I've reloaded the egg file but still get the error. Any ideas? Do I  
>>  just need to change a path or something similar as Python is a new  
>>  language to me?
> By the way for the runserver command to work you'll want to have
> installed with the web_gui option:
> easy_install -Z shakespeare[web_gui]


Iain Emsley

Blog: www.yatterings.com
Mobile: 07942 259725

More information about the okfn-help mailing list